undefined function

i have used this app before on godaddy shared hosting it’s worked perfectly
but now i have transfered my site to a new VPS when i tried to use the app this error shows to me

Fatal error: Call to undefined function mb_convert_encoding() in /home/elnhrda/public_html/full-rss/1/libraries/readability/Readability.php on line 114

this is the link :

i have a root access 7 can make any changes in the vps to get the app works fine

any suggestion would be appreciated

Hi Adnan, sounds like you don’t have the mbstring extension installed. Our compatibility test points this out: http://elnhrda.com/full-rss/1/ftr_compatibility_test.php

If you’ve installed PHP as a package, you might have to install mbstring separately, see http://www.electrictoolbox.com/mbstring-php-extension-not-found-phpmyadmin/ or http://stackoverflow.com/questions/9692157/php-missing-mb-strpos-function
Otherwise have a look at http://www.php.net/manual/en/mbstring.installation.php

Hope that’s some help.

thanks for helping me … my problem now solved :slight_smile: