title with quotes " " returns "Με χαράκωσαν

the title of the rss once passed through fivefitlers becomes “Με χαράκωσαν οι χρυσαυγίτες”

and that happens in cases where the title contains quotes " " in greek. What is the fix for that? thanks.

Ionnis, do you have a URL I can try out to see if I can reproduce this problem?

i can’t give you the rss because it has changed and changes constantly and not all titles have quotes.

here is a page http://news247.gr/eidiseis/katatheseis_fwtia_htan_apofasismenoi_akomh_kai_na_afairesoyn_zwes_an_thewrousan_oti_to_thuma_htan_antipalos_toys.2433351.html

if you can take the title and pass it through the script you might reproduce it.thanks!


Hi Ioannis, I couldn’t reproduce this. Do you have the same trouble when you use that URL in our hosted version? http://fivefilters.org/content-only/

I did notice that double quotes in the article’s title do not appear in the Full-Text RSS result, but that’s because they do not appear in the title element in the HTML header (which is where Full-Text RSS was grabbing it from). We’ve added a site config file for this site to improve extraction and to use the article title which appears in the HTML body: https://github.com/fivefilters/ftr-site-config/blob/master/news247.gr.txt

Thanks Keyvan,

It seems it’s not the double quotes, because i tested again on my version and quotes work…i could not test in your version it only showed me the 3 first in the rss no matter if i changed the option.

Anyway, i will keep you updated when i meet this in specific rss.Some kind of encoding problem either in the script itself or my server PHP maybe.

Thanks a lot for looking into this.


Ok, no problem. Let me know if you come across the problem again.

Our free, hosted service only process up to 3 items per feed. But if it’s an issue for a certain article, you can paste the article URL in rather than the feed, and we’ll create a 1-item feed for that article.

hi, i nailed it again on a random feed.

its title gives me 7 άλλ’ αντ’ άλλα του ΣΔΟΕ για τις 5 λίστες επωνύμων

the thing is through your site it works fine…so what could it be? any suggestions? some kind of encoding problem but where?


actually when i write “its title gives me” i was seeing something like this : 0;κωσαν οι χρυσαυ&ga and then when i posted it’s normal again!!
lol what is going on…


i think it is the feed reader or the browser i use firefox


I Ionnis, this is strange. I can’t reproduce the problem locally or on fivefilters.org. I tried on Chrome and Firefox. If it happens again, could you enable debug mode (check the debug checkbox) and send us the output. Thanks.

hi Keyvan, it happened again, it is the third item on the feed. thanks for taking a look.


Hi Ioannis, I’m afraid I can’t reproduce this. I tried checking results in Chrome and Firefox, and both look fine. If you think it might be a server issue, you could try hosting somewhere else and see if you experience the same issue. Not sure what else to suggest.

Hi keyvan, first of all thanks a lot for looking into it.
I changed server, same thing, i’ am sure it is some kind of utf8 encoding error all the weird stuff like &epsilon &alpha, is how the encoding of utf8_general_ci? might represent the data. I actually tried to read the erroneous feed with another feed reader and the problem was gone!
it is really weird, i have utf_unicode_ci everywhere on my server should not have any problems, and if it were a script issue you would be able to reproduce it…
anyway…thanks it’s not a big deal but it happens from time to time.
take care!


hi again, see for a last time if you can replicate the problem on this feed



Okay Keyvan MYSTERY solved! after tinkering with php.ini making sure it has charset utf8 my web server nginx has also utf8 and ofcourse mysql…nothing worked…
then I tried chrome web browser…tataaa problem gone. It was damn Firefox, and I although I had selected utf-8 it wasn’t working correctly!


HI Ioannis, that’s very strange. I’m glad you managed to get it working in the end. Thanks for the update.