Problem with escaping characters

If I use the form and enter ‘’ (without quote) in the URL feed, it generates the feed.

However if I try to use the generated feed, FTR is unable to retrieve the full content

This is how it encodes the URL in the generated feed:

If I try with the URL encoded using Meyerweb tools:
it still doesn’t work.

BTW if I try the encoded URL in the form, it generates an Invalid URL supplied message (and debug doesn’t help).

As it works fine when decoded in the form I strongly suspect something is not handling the decoding correctly somewhere.

Hi David,

I’m not sure I understand. If you use the form to enter the URL, the URL you see in your browser’s address bar after you click ‘Create Feed’ should be correct. If I try this on I get:

Can you load this okay in your browser? If you’re giving this URL to some other application and it’s not working in that application, it might be the way that application is handling the URL that’s at fault.

By the way, you shouldn’t use an encoded URL in the form as it will get encoded again by your browser. We only suggest encoding the URL when you’re constructing the final Full-Text RSS URL by hand, or within code - in both these cases you need to append the encoded URL after ?url= - but when you’re using our web form, the browser handles the encoding and expects a standard unencoded URL.

Thank you about the clarification re encoding.

While trying to give clearer examples, it now works. So it was likely a ‘user error’. Sorry for the inconvenience.


I think I found what confused me. You guessed right it is in fact a problem with an app. It seems that when adding the feed with Newsblur it works fine, but by the time Newsblur refreshes it, it has decoded the characters.

Unfortunately it looks like this behaviour was reported two years ago, but Samuel has not yet dealt with it. I’ve refreshed it:[settings][filter_by]=all&topic-reply-list[settings][page]=1#reply_15874162

If anyone else is using Fivefilters with Newsblur and encoded feed, please add to this NewsBlur bug report so that Samuel may eventually fix this.


BTW, the url you suggest I try is truncated. So any reader trying it, it will fail unless you also add the missing bit!


Thanks David, interesting issue with Newsblur. One thing you might want to try as a temporary measure is using a URL shortener on one of the problem feed URLs and see if that works better. (Depending on the HTTP implementation, the encoding might not be an issue when it’s handled at a lower level by the HTTP library handling the redirect.)

Sorry about the URL, I can see it fine here, but the public view of the forum doesn’t handle long strings well. Here’s the shortened version for anyone wanting to test:

Great idea. Thank you.

(The other way around I’ve used FTR to make a twitter search acceptable to Newsblur and also improve a little bit what is included!)