Medium not extracting fulltext


#1

The first few times I used Push to Kindle on Medium.com articles it worked flawlessly…and now it just gives the first few lines as a preview? I have a paid account on Medium and am a Patreon member on Five Filters so I hope I am not hitting some limitation I am unaware of? Thanks for any advice!


#2

Hi Joshua, I’m sorry about the trouble. I tried a few Medium articles and it worked for me here. Could you perhaps send us the URLs to the article you’re having trouble with so we can look into it a little more? (Perhaps it’s struggling with certain articles and not others.)


#3

Thanks for following up! I think it is just on certain articles- that’s my guess at least. I’m guessing websites can put a do not print notation in the code somewhere? It works on 70% of the articles, and when it doesn’t I can always just use paste pad which is awesome too.

One example would be: https://medium.com/aeon-magazine/the-fallacy-of-obviousness-1d7a29024c37 If there is a way to fix it that would be great too! But I am guessing not.


#4

Hi Joshua, thans for providing more information.

The problem appears to be that certain Medium articles are not public - you have to be signed in to view them. This last one is like that. Push to Kindle at the moment makes its own request for content, and sees what a regular user not signed into the site would see. We are working on an update which will send the content you see in your browser to the service for processing. So if you are a premium Patreon member, you’ll be able to send premium content. We hope to have this ready soon.