I can't set author for feeds from RSS-Bridge

I wrote this on Guthub, but I think the right place is here, isn’t it?

I host RSS-Bridge and FTR locally. I use the FeedMergeBridge.php to merge 5 sub-feeds of the same site to a single one, so FreshRSS can sort out duplicates. Between them is FullTextRSS (FTR) which takes the full articles. This works great!

But FTR sets the author field dc:creator to literal ‘RSS-Bridge’ and I can’t find out how to get rid of that. I tried to find out how to do that on RSS-Bidge side, but that is too heavy for me. RSS-Bridge set this as the feed-author and ftr uses this as item author instead of the matched one from the article.

So I made configs in FTR both for my ip-address of RSS-Bridge and for the original site, where the full-text-content is from.

While the debug mode shows, that FTR found a correct match for the author, this is not passed to the outgoing feed. That match comes from the original site config. I added to existing diepresse.com.txt:

author: //span[@class='author__name']
author: '-'

Some articles have no author, so the second line would catch that. Will this change to empty string when I get arround the problem. I uploaded both, the feed from bridge and the feed from FTR to the github issue.

So how to override this feed-author field from RSS-Bridge?

The examples:

Bridge and FTR are not exposed to the internet, so no link, sorry

Hi there,

Sorry we missed your Github Issues post.

We should really document this aspect of Full-Text RSS. Currently the author name extracted from the article is only used when the input feed doesn’t contain author information. If the input feed has author info, it’s always prioritised. If you have control over the input feed and can remove the author info from it, then the extracted author should be used in the feed Full-Text RSS produces.

We’ll introduce a request parameter in a future version to override this behaviour, as we have with ‘use_extracted_title’, which you can use to tell Full-Text RSS that the extracted article title should replace any title in the source feed.

The next problem with my combination was for timing. Getting 5 feeds, filter duplicates, joining them to one feed and get fulltext causes fresh-RSS to say, the feed is not available. But it was just a timeout. So I wrote a little script which is run by cron job every 20 min as user www-data. This gave me the oportunity to fix the author-problem in the script. I just renamed the “author”-field to “origin” The path in first row is accessible by browsers and freshRSS in local net via http://xxx.example.com/feeds.

cd /var/www/somewhere/feeds
curl -s --connect-timeout 180 -m 180 -o fileneame.rss "http://rssbridge.example.com:3000/?action=display&bridge=Selfmade&format=Atom"
sed -i 's/author>/origin>/g' filename.rss
curl -s --connect-timeout 180 -m 180 -o filename-ftr.rss "https://example.com/ftr/makefulltextfeed.php?url=https%3A%2F%2Fxxx.example.com%2Ffeeds%2Ffilename.rss&max=30&links=preserve&exc="

And the FreshRSS (the feed agregator) now gets the feed via local xxx.example.com/feeds/filename-ftr.rss

1 Like