Articles arrive on Kindle but don't download?

I’m not sure if this a software or a hardware issue, maybe someone can help? I use the bookmarklet on Chrome on desktop, and the Android Chrome share menu button on mobile.

Recently articles sent to my Kindle seem to arrive, but they don’t actually seem to download and cannot be opened or read. In the attached photo the top 2 articles are not readable, while the bottom 2 are.

When I try and manually download the troublesome articles, I briefly see ‘queued’, but then it disappears and it reverts to this state.

I’ve restarted several times, tried manually syncing, and checked my document sending/receiving details. I can’t think what else to try.

Any ideas??

Strange. I’d want to rule out causes other than Push to Kindle first. If you’re able to, could you try sending a Kindle ebook from somewhere else (but not purchased from Amazon) to your address? For example, try the following steps:

  1. Visit Gutenberg’s top 30 books page and download one of the Kindle versions (ending in .mobi):

  2. Attach it to an email to your address and send

  3. Wait for it to appear on your Kindle (similar to the items in your screenshot)

  4. Try tapping and downloading the item and see if that works.

If your Kindle is able to download and load that, but not our items, then it’s likely an issue we need to investigate. But if you have the same problem with that, then I think it’s either a storage issue, a Kindle issue, or an issue with Amazon’s Send to Kindle service.

Please let us know how you get on.

Thanks for the response.

I sent an ebook as per those steps and it doesn’t seem to arrived (as in, I don’t even see the title on my device).

I then also tried to send an article to my device using Amazon’s own Send to Kindle Chrome extension. This resulted, again, in the article appearing on the device but not actually downloading.

There’s 2.25GB available on the device, so I think that rules out storage.

I would imagine if it was being caused by Amazon’s Send to Kindle Service it would be a widespread issue?

So that would seem to suggest it’s the device. Would you agree? I guess I need to try the official Amazon support channels…


Hi Stuart, I think you’re right about that. We haven’t been able to reproduce this issue ourselves, and haven’t had any other reports of it. So I would suggest you contact Amazon support for help.